SEO форум вебмастеров TalkWebber.ru

Чтобы пользоваться всеми его возможностями, необходимо зарегистрироваться. Без регистрации Вы сможете только читать определенные темы. Мы будем благодарны, если Вы примите участие в нашем проекте и будете развивать форум вместе с нами!

  • Хотите поместить баннер на наш сайт или закрепить свою тему с цветом? Зайдите в эту тему!

Проблема с выводом ошибки DLE

uiivalet

Гость
Пользователь
Регистрация
08.11
Сообщения
7
Репутация
2
#1
в main.tpl есть

......
[not-aviable=main]
{info}
{content}
[/not-aviable]
......
но ошибки не выводятся никакие вообще. Если поменять шаблон на стандартный, то ошибки выводятся и все нормально. Главное сначала всё работало, а потом вдруг перестало.
Файл info.tpl присутствует

<div class="s-block">
<div class="title-block">
{title}
</div>
<div class="s-block-content">
<div class="error">{error}</div>
</div>
</div>
Речь идет о стандартной ошибке:
Внимание, обнаружена ошибка
По данному адресу публикаций на сайте не найдено, либо у вас нет доступа для просмотра информации по данному адресу.
Вместо вывода ошибки правый блок сдвигается и пустота.

DLE лицензионная 10,2
На локальном сервере денвера шаблон отображается как надо.
 

hell

Talkwebber'овиц
Проверенные
Регистрация
11.09
Сообщения
2,821
Репутация
1,760
#2
Ну в дефолтном шабе

<div class="clr berrors">
<b>{title}</b><br />
{error}
</div>
и в css
Код:
/*---Вывод ошибок---*/
.berrors {
    border: 1px solid #6d4595;
    border-width: 1px 0;
    color: #e0cdf3;
    padding: 10px 15px 10px 60px;
    font-style: italic;
    background: #96c url("../images/berrors.png") no-repeat;
}

.berrors a {
    color: #fff;
}
 

uiivalet

Гость
Пользователь
Регистрация
08.11
Сообщения
7
Репутация
2
#3
hell, ну то что в дефолтном стоит я видел, но в моем не хочет отображать ошибки, хотя работало всё отлично
мой css

/* Инфо */
.error {
padding: 10px;
padding-bottom: 150px;
background: url(../images/error.jpg) center bottom no-repeat;
text-align: center;
}

.error p {
font-size: 15px;
font-weight: bold;
}

.error a {
color: #7cad37;
}
я даже не знаю что могло случится и где копать
 

hell

Talkwebber'овиц
Проверенные
Регистрация
11.09
Сообщения
2,821
Репутация
1,760
#4
Ссылку на сайт в личку скинь посмотрю пока время есть
 

uiivalet

Гость
Пользователь
Регистрация
08.11
Сообщения
7
Репутация
2
#5
Проблема так и осталась не решенной. Может всё же кто сталкивался с этим и может помочь?
Опишу ещё раз суть проблемы:
на сайте не выводятся ошибки вида
Внимание, обнаружена ошибка
По данному адресу публикаций на сайте не найдено, либо у вас нет доступа для просмотра информации по данному адресу.

допустим введем: site/bred, и вместо вывода ошибки, т.к. такой страницы нет, открывается пустая главная страница (отклик сервера поисковых систем при этом 200 ОК вместо 404)
такая проблема наблюдается в любых шаблонах, кроме стандартных

тег {info} в main.tpl присутствует
info.tpl имеется
css прописаны
версия DLE 10.2 (лицензия)
хостинг reg.ru

экспериментальным путем было достигнуто, что на другом хостинге и локальном сервере денвера, всё работает отлично
в чем же может быть проблема?
 

uiivalet

Гость
Пользователь
Регистрация
08.11
Сообщения
7
Репутация
2
#6
и так, дошел до того, что если в DLE сделать бэкап БД и перенести на денвер, то ошибка наблюдается, в итоге проблемы с хостером как я понял отпадают
люди, помогите же пожалуйста
 

hell

Talkwebber'овиц
Проверенные
Регистрация
11.09
Сообщения
2,821
Репутация
1,760
#7
Ты ещё не загнался )) Проще тогда базу с файлами кинуть на норрмальный хостинг и глянуть. Щя попробую отдельный доступ слепить и в личку скину. Заодно и провериш. А то так точно загонишся
 

daiv777

WWW
Пользователь
Регистрация
04.11
Сообщения
788
Репутация
225
#9
uiivalet написал(а):
в main.tpl есть

......
[not-aviable=main]
{info}
{content}
[/not-aviable]
......
но ошибки не выводятся никакие вообще. Если поменять шаблон на стандартный, то ошибки выводятся и все нормально. Главное сначала всё работало, а потом вдруг перестало.
Файл info.tpl присутствует

<div class="s-block">
<div class="title-block">
{title}
</div>
<div class="s-block-content">
<div class="error">{error}</div>
</div>
</div>
Речь идет о стандартной ошибке:
Внимание, обнаружена ошибка
По данному адресу публикаций на сайте не найдено, либо у вас нет доступа для просмотра информации по данному адресу.
Вместо вывода ошибки правый блок сдвигается и пустота.

DLE лицензионная 10,2
На локальном сервере денвера шаблон отображается как надо.
Заработало?
 

uiivalet

Гость
Пользователь
Регистрация
08.11
Сообщения
7
Репутация
2
#10
daiv777, премного благодарен, всё отлично.
 

hell

Talkwebber'овиц
Проверенные
Регистрация
11.09
Сообщения
2,821
Репутация
1,760
#11
Раз пошла такая пьянка )) С какого х у меня работает всё что у других не пашет ( И в 10,1 этой стоки ваще нету
 

uiivalet

Гость
Пользователь
Регистрация
08.11
Сообщения
7
Репутация
2
#12
Я пока не понял откуда эта проблема взялась.
Заметил это ещё на версии 10.1, обновление 10.2 результатов не дало, пока не закоментировал эту строку.
 

hell

Talkwebber'овиц
Проверенные
Регистрация
11.09
Сообщения
2,821
Репутация
1,760
#13
В 10,1 нету этой строки